<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://volumes.blog/xmlrpc.php">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="3wZT7sUd08L0kBtnR404qG1xlioF5o0lAWHUhg95xt4" />

	<!-- This site is optimized with the Yoast SEO plugin v17.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>DELL EMC PowerScale CSI Driver: ReadWriteMany Volumes and Volume Snapshots for VMware vSphere with Tanzu - Itzikr&#039;s Blog</title>
	<link rel="canonical" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="DELL EMC PowerScale CSI Driver: ReadWriteMany Volumes and Volume Snapshots for VMware vSphere with Tanzu - Itzikr&#039;s Blog" />
	<meta property="og:description" content="With the distributed and dynamic nature of containers, managing and configuring storage statically has become a challenge on Kubernetes, with workloads now being able to move from one worker node [&hellip;]" />
	<meta property="og:url" content="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/" />
	<meta property="og:site_name" content="Itzikr&#039;s Blog" />
	<meta property="article:published_time" content="2021-11-02T07:29:51+00:00" />
	<meta property="article:modified_time" content="2021-11-02T07:29:52+00:00" />
	<meta property="og:image" content="https://volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe1.png" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@itzikr" />
	<meta name="twitter:site" content="@itzikr" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="itzikr" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="6 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Itzikr&#039;s Blog &raquo; Feed" href="https://volumes.blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="Itzikr&#039;s Blog &raquo; Comments Feed" href="https://volumes.blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Itzikr&#039;s Blog &raquo; DELL EMC PowerScale CSI Driver: ReadWriteMany Volumes and Volume Snapshots for VMware vSphere with Tanzu Comments Feed" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/volumes.blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-580811e355b148c7f8aaf11822c0ad7d' href='https://volumes.blog/_static/??-eJyNUtFuwyAM/KExWq3q27RPmQh41I2DEYZ2+fs53SqlXarmJfKB7zhffM7Gc6qQqs3UIiaxR6jZ+d4OHBqB2ALkKgSTWeodevUiL+f/ErEp7KBE2zWkYDti3xvCrrgyWqkjwSMquZFbNbFguG3E5KkF9XMUO0BABwTDxJyDrHQohiA6P74OmJ6y9W6O55yrtXrQK52cByj8a0qs9ljlVS7mMt3DLO7jJOz1u5jBwkPPVD91MBshQUFtkeVyrTVpnfiCueLEv0FrJc4YIuiafDkPHfP003stvtdNc1W5BGEqM00LJ1kN4AnMCQPwwsnq+Q6uQHAhjJcSU1wVr7BHR4Y46uNzsLQs9wrTnvzVU+vH8L7dv+22u812v/kB1etYSA==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link crossorigin="anonymous" rel='stylesheet' id='romero-fonts-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700%7COpen+Sans%3A400%2C700&#038;subset=latin%2Clatin-ext' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script type='text/javascript'  src='https://volumes.blog/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?m=1633452470'></script>
<script src='https://volumes.blog/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script id='romero-script-main-js-extra'>
var js_i18n = {"next":"next","prev":"previous","menu":"Menu"};
</script>
<script type='text/javascript'  src='https://volumes.blog/_static/??wp-includes/js/jquery/jquery-migrate.min.js,wp-content/themes/romero/js/main.js?m=1609869186'></script>
<link rel="https://api.w.org/" href="https://volumes.blog/wp-json/" /><link rel="alternate" type="application/json" href="https://volumes.blog/wp-json/wp/v2/posts/8571" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://volumes.blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://volumes.blog/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/ptYyI-2ef' />
<link rel="alternate" type="application/json+oembed" href="https://volumes.blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvolumes.blog%2F2021%2F11%2F02%2Fdell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://volumes.blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvolumes.blog%2F2021%2F11%2F02%2Fdell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		<style type="text/css">
.widget_twitter li {
	word-wrap: break-word;
}
</style>
<style>
	.masthead h1.site-title a,
	.masthead h1.site-title a:hover,
	.masthead h2.site-description {
		color:#000000;
	}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #343b4f; }
</style>
	<link rel="amphtml" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/amp/">			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<style type="text/css" id="custom-colors-css">body.blog .main{color:#afafaf}.masthead .menu-primary #sidebar-menu-toggle:before,.main .pagination span.current,article .post-lead-category a,.infinite-scroll #infinite-handle span,.infinite-scroll #infinite-handle span:hover,#sidebar-menu .widget h3.widgettitle,#sidebar-menu .widget{color:#666}.sidebar-main .widget_calendar thead,.sidebar-main .widget_calendar tbody,.sidebar-main .widget_calendar tfoot,.sidebar-main #wp-calendar a{color:#6d6d6d}.sidebar-main,.sidebar-main .widget a,body .archive,body .blog{color:#afafaf}.sidebar-main .widget{color:#afafaf}.entry-title,.sidebar-main h1,.sidebar-main h2,.sidebar-main h3,.sidebar-main h4,.sidebar-main h5,.sidebar-main h6,h3#comments,h3#comments a,#reply-title{color:#afafaf}.main-content h1,.main-content h2,.main-content h3,.main-content h4,.main-content h5,.main-content h6,.sidebar-footer h1,.sidebar-footer h2,.sidebar-footer h3,.sidebar-footer h4,.sidebar-footer h5,.sidebar-footer h6{color:#1a1a1a}.masthead .menu-primary a,.masthead .actions .menu-primary a,article.post-archive h2.entry-title a{color:#afafaf}.showcase article.post-archive h2.entry-title a{color:#000}.masthead .menu li.page_item_has_children>a:after,.masthead .menu li.menu-item-has-children>a:after{border-top-color:#afafaf}#sidebar-menu .widget a{color:#2b66b9}.blog .main a{color:#89b4e6}.blog .main a:hover{color:#89b4e6}.masthead .menu li.current-menu-item>a{background-color:#ccc}.masthead .menu li.current-menu-item>a{color:#000}body,.masthead .menu-primary{background-color:#343b4f}header.header-overlap,.content-comments{background:#3e475f}input[type=submit],.infinite-scroll #infinite-handle span,.screen-reader-shortcut,.main .contributor a.contributor-posts-link,.masthead .menu-primary #sidebar-menu-toggle:before,.main .pagination span.current,article .post-lead-category a,#sidebar-menu{background:#ebf3ff}input[type=text]:focus,input[type=password]:focus,input[type=email]:focus,input[type=url]:focus,input.text:focus,textarea:focus,select:focus,input.settings-input:focus{outline-color:#ebf3ff}input[type=text]:focus,input[type=password]:focus,input[type=email]:focus,input[type=url]:focus,input.text:focus,textarea:focus,select:focus,input.settings-input:focus,.sidebar-main .widget:before{border-color:#ebf3ff}.sidebar-main .widget.widget_flickr #flickr_badge_uber_wrapper td a,.sidebar-main .widget.widget_flickr #flickr_badge_wrapper td a,a,.sidebar-footer a{color:#145eff}.main .post-navigation .nav-previous a:hover,.main .post-navigation .nav-next a:hover,article.post-archive h2.entry-title a:hover,.sidebar-main .widget a:hover,.menu-social-links ul li a:hover:before,.widget a:hover{color:#ebf3ff}a:hover{color:#f2f7ff}article .post-lead-category a:hover,.masthead .menu-primary #sidebar-menu-toggle:hover::before,.infinite-scroll #infinite-handle span:hover{background:#f2f7ff}.sidebar-menu .widget:before{border-color:#f2f7ff}</style>
<link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="32x32" />
<link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://s0.wp.com/i/webclip.png" />
<meta name="msapplication-TileImage" content="https://s0.wp.com/i/webclip.png" />
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-52391254-2']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
</head>

<body class="post-template-default single single-post postid-8571 single-format-standard custom-background wp-custom-logo wp-embed-responsive singular multi-author-false themes-sidebar1-active themes-sidebar2-active themes-no-featured-posts themes-sidebar-menu-inactive widgets-hidden custom-colors has-site-logo">

<a href="#main-content" class="screen-reader-shortcut">Skip to content</a>

<header class="masthead" role="banner">

	<div class="container" id="header-wrapper">
		<div class="action-wrapper">

			<div class="branding">
				<h1 class="site-title">
					<a href="https://volumes.blog/" class="site-logo-link" rel="home" itemprop="url"><img width="102" height="120" src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?fit=102%2C120&amp;ssl=1" class="site-logo attachment-romero-logo jetpack-lazy-image" alt="" loading="lazy" data-size="romero-logo" itemprop="logo" data-attachment-id="8255" data-permalink="https://volumes.blog/about/itzik-004/" data-orig-file="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?fit=3046%2C3589&amp;ssl=1" data-orig-size="3046,3589" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark IV&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1626175628&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;70&quot;,&quot;iso&quot;:&quot;400&quot;,&quot;shutter_speed&quot;:&quot;0.00625&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="itzik-004" data-image-description="" data-image-caption="" data-medium-file="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?fit=255%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?fit=760%2C896&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?w=3046&amp;ssl=1 3046w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?resize=255%2C300&amp;ssl=1 255w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?resize=869%2C1024&amp;ssl=1 869w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?resize=768%2C905&amp;ssl=1 768w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?resize=1304%2C1536&amp;ssl=1 1304w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?resize=1738%2C2048&amp;ssl=1 1738w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?resize=1200%2C1414&amp;ssl=1 1200w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?resize=102%2C120&amp;ssl=1 102w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?resize=1140%2C1343&amp;ssl=1 1140w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?w=1520&amp;ssl=1 1520w, https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?w=2280&amp;ssl=1 2280w" data-lazy-sizes="(max-width: 102px) 100vw, 102px" data-lazy-src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/07/itzik-004.jpg?fit=102%2C120&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>					<a href="https://volumes.blog/" title="Home" class="site-title-link">
						Itzikr&#039;s Blog					</a>
				</h1>
				<p class="site-description">
					Dell EMC Storage, PowerStore, PowerFlex PowerMax &amp; XtremIO, Virtualization &amp; Containers Technologies				</p>
			</div>

			<div class="actions">
				<div class="secondary">
										<form method="get" class="search-form" action="https://volumes.blog/" role="search">
	<label>
		<span class="screen-reader">Search for...</span>
		<input type="search" value="" name="s" class="search-field text" placeholder="Search..." />
	</label>
	<button class="search-submit">&#62464;<span class="screen-reader">Search</span></button>
</form>
				</div>

				<nav class="menu-primary menu" role="navigation">
					<h3 class="menu-toggle">Menu</h3>
<div id="nav" class="menu-wrap"><ul>
<li class="page_item page-item-2"><a href="https://volumes.blog/about/">About</a></li>
</ul></div>
				</nav>
			</div>
		</div>
	</div>

	<div class="container container-sidebar-menu">
			</div>

	<div class="container container-header">
	</div>

</header>
<article id="post-8571" class="featured-post" style="background-image:url(https://i2.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe1.png?resize=1052%2C568&#038;ssl=1)" >
	<a href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/" class="permalink"><span class="screen-reader-text">DELL EMC PowerScale CSI Driver: ReadWriteMany Volumes and Volume Snapshots for VMware vSphere with Tanzu</span></a>
	<section class="entry entry-archive">
		<div class="container">
	<span class="post-lead-category"><a href="https://volumes.blog/category/uncategorized/">Uncategorized</a></span>
			<h2 class="entry-title">
				<a href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/" rel="bookmark">
					DELL EMC PowerScale CSI Driver: ReadWriteMany Volumes and Volume Snapshots for VMware vSphere with Tanzu				</a>
			</h2>
			<div class="excerpt"><p>With the distributed and dynamic nature of containers, managing and configuring storage statically has become a challenge on Kubernetes, with workloads now being able to move from one worker node [&hellip;]</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-8571" class="share-twitter sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-8571" class="share-linkedin sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-8571" class="share-facebook sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-7144304-8571-6183630130955' data-src='https://widgets.wp.com/likes/#blog_id=7144304&amp;post_id=8571&amp;origin=volumes.blog&amp;obj_id=7144304-8571-6183630130955' data-name='like-post-frame-7144304-8571-6183630130955' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>
		</div>
	</section>
</article>
	<div class="container hfeed">
		<div class="main">
			<div class="main-content article">
<article id="post-8571" class="post-8571 post type-post status-publish format-standard hentry category-uncategorized post-singular post-has-thumbnail">
	<section class="entry entry-single">
<p><span style="color: #222222;">With the distributed and dynamic nature of containers, managing and configuring storage statically has become a challenge on Kubernetes, with workloads now being able to move from one worker node to another in a matter of seconds. To address this, Kubernetes manages volumes with a system of <a href="https://www.digitalocean.com/community/tutorials/an-introduction-to-kubernetes">Persistent Volumes (PV)</a>, API objects that represent a storage configuration/volume, and <a href="https://kubernetes.io/docs/concepts/storage/persistent-volumes/">PersistentVolumeClaims (PVC)</a>, a request for storage to be satisfied by a Persistent Volume. Additionally, <a href="https://kubernetes.io/blog/2019/01/15/container-storage-interface-ga/">Container Storage Interface (CSI)</a> drivers can help automate and manage the handling and provisioning of storage for containerized workloads. These drivers are responsible for provisioning, mounting, unmounting, removing, and snapshotting volumes.<br />
</span></p>
<p><span style="color: #222222;">A </span>PersistentVolumeClaim<span style="color: #222222;"> (PVC) is a request for storage by a user. It is similar to a Pod. Pods consume node resources and PVCs consume PV resources. Pods can request specific levels of resources (CPU and Memory). Claims can request specific size and access modes<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">A PersistentVolume can be mounted on a worker node in any way supported by the resource provider. Different providers have different capabilities and each PV&#8217;s access modes are set to the specific modes supported by that particular volume. For example, NFS can support multiple read/write clients, but a specific NFS PV might be exported on the server as read-only. Each PV gets its own set of access modes describing that specific PV&#8217;s capabilities.<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">The access modes are:<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">ReadWriteOnce: the volume can be mounted as read-write by a single node. ReadWriteOnce access mode still can allow multiple pods to access the volume when the pods are running on the same node.<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">ReadOnlyMany: the volume can be mounted as read-only by many nodes.<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">ReadWriteMany: the volume can be mounted as read-write by many nodes.<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">ReadWriteOncePod: the volume can be mounted as read-write by a single Pod. Use ReadWriteOncePod access mode if you want to ensure that only one pod across whole cluster can read that PVC or write to it. This is only supported for CSI volumes and Kubernetes version 1.22+.<br />
</span></p>
<p><span style="color: #222222;">Using the VMware CNS driver – the built in the VMware CSI driver for vSphere with Tnazu, it&#8217;s not possible to create ReadWriteMany volumes on VMFS, vVOL or NFS datastores.<br />
</span></p>
<p><span style="color: #222222;">However, this capability can be achieved using the external PowerScale CSI driver by creating the PVs directly on PowerScale. This functionality is also supported by PowerStore and Unity storage arrays.<br />
</span></p>
<p><span style="color: #222222;">ReadWriteMany volumes are volumes that can be mounted in a Read/Write fashion simultaneously into a number of pods. This is particularly useful for web and app servers that serve the same files &#8211; but also for CI systems like Jenkins which can use a shared volume for artifact storage rather than unnecessarily duplicating data and impacting CI performance.<br />
</span></p>
<p><span style="color: #222222;">The PowerScale CSI driver integrates a Kubernetes cluster with the <a href="https://www.digitalocean.com/products/block-storage/"> DELL EMC PowerScale Storage product</a>. A developer can use this to dynamically provision ReadWriteOnce volumes for containerized applications in Kubernetes. However, applications can sometimes require data to be persisted and shared across multiple pods. ReadWriteMany volumes are volumes that can be mounted in a Read/Write fashion simultaneously into a number of pods. This is particularly useful for web and app servers that serve the same files &#8211; but also for CI systems like Jenkins which can use a shared volume for artifact storage rather than unnecessarily duplicating data and impacting CI performance.<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">PowerScale CSI driver supports ReadWriteMany (RWX) <a href="https://kubernetes.io/docs/concepts/storage/persistent-volumes/">access mode</a> Persistent Volumes. A RWX PVC can be used simultaneously by many Pods in the same Kubernetes namespace for read and write operations.<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">To create a ReadWriteMany (RWX) volume with PowerScale, create a Persistent Volume Claim (PVC) with an access mode of ReadWriteMany<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">The following YAML manifest files provide an example:<br />
</span></p>
<p style="background: white;"><span style="color: #222222;">A 10Gi PVC with the powerscale storageClassName, with an accessMode of ReadWriteMany:<br />
</span></p>
<p style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"><span style="color: #204a87;"><strong> apiVersion: </strong></span>v1<span style="text-decoration: underline;"><br />
</span></span></p>
<ol>
<li>
<div style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"><span style="color: #204a87;"><strong>kind: </strong></span>PersistentVolumeClaim<span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></div>
</li>
</ol>
<p style="background: #f8f8f8;"><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> metadata:<br />
</strong></span></p>
<p style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"><span style="color: #204a87;"><strong> name: </strong></span>external-nfs-pvc<br />
</span></p>
<p style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"><br />
<span style="color: #204a87;"><strong>spec:<br />
</strong></span></span></p>
<p style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"><span style="color: #204a87;"><strong> storageClassName:</strong></span> powerscale<br />
</span></p>
<p style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"><br />
<span style="color: #204a87;"><strong>accessModes:<br />
</strong></span></span></p>
<p style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"> &#8211; ReadWriteMany<br />
</span></p>
<p style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"><br />
<span style="color: #204a87;"><strong>resources:<br />
</strong></span></span></p>
<p style="background: #f8f8f8;"><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> requests:<br />
</strong></span></p>
<p style="background: #f8f8f8;"><span style="font-family: Consolas; font-size: 10pt;"><br />
<span style="color: #204a87;"><strong>storage:</strong></span> 10Gi<br />
</span></p>
<p><span style="color: #222222;">By navigating to powerscale OneFS, and clicking on the FS explorer, we can see that the new PV has been created successfully.<br />
</span></p>
<p><img src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe1.png?w=760&#038;ssl=1" alt data-recalc-dims="1" data-lazy-src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe1.png?w=760&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe1.png?w=760&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript><span style="color: #222222; font-family: Open Sans;"><br />
</span></p>
<p><span style="color: #222222;">To demonstrate how we can read and write data simultaneously from multiple pods using the PowerScale CSI driver, I deployed two NGINX pods and specified the same claim name under the PVC section.<br />
</span></p>
<p><span style="font-family: Consolas; font-size: 10pt;"><span style="color: #204a87;"><strong>apiVersion: </strong></span>v1<span style="color: #204a87;"><strong><br />
</strong></span></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>kind: Pod<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>metadata:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> name: external-nfs-pod-1<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>spec:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> volumes:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> &#8211; name: external-nfs-storage<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> persistentVolumeClaim:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> claimName: <span style="background-color: yellow;">external-nfs-pvc</span><br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> containers:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> &#8211; name: external-nfs-container<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> image: nginx<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> ports:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> &#8211; containerPort: 80<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> name: &#8220;http-server&#8221;<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> volumeMounts:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> &#8211; mountPath: &#8220;/usr/share/nginx/html&#8221;<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> name: external-nfs-storage<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>&#8212;<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>apiVersion: v1<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>kind: Pod<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>metadata:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> name: external-nfs-pod-2<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>spec:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> volumes:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> &#8211; name: <span style="background-color: yellow;">external-nfs-storage</span><br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> persistentVolumeClaim:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> claimName: external-nfs-pvc<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> containers:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> &#8211; name: external-nfs-container<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> image: nginx<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> ports:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> &#8211; containerPort: 80<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> name: &#8220;http-server&#8221;<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> volumeMounts:<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> &#8211; mountPath: &#8220;/usr/share/nginx/html&#8221;<br />
</strong></span></p>
<p><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong> name: external-nfs-storage<br />
</strong></span></p>
<p><span style="color: #222222; font-family: Open Sans;">We can see below that files that we create and update on one pod are available on the other, and changes we make in either pod are reflected in both &#8211; this makes sense as they are sharing the same volumes and proves that everything is working as planned.<br />
</span></p>
<p><img src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe2.png?w=760&#038;ssl=1" alt data-recalc-dims="1" data-lazy-src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe2.png?w=760&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe2.png?w=760&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript><span style="color: #036ccf; font-family: Arial; font-size: 28pt;"><br />
</span></p>
<p style="background: white;"><span style="color: #222222; font-size: 18pt;">Volume Snapshot Feature for vSphere with Tanzu<br />
</span></p>
<p><span style="color: #222222; font-size: 12pt;">Another very using CSI feature is volume snapshots, the ability to create and manage snapshots of existing persistent volume, this feature is not supported by the CNS driver – the built in the VMware CSI driver so we will use the PowerScale CSI driver to show you how we can leverage the native PowerScale snapshots mechanism for vSphere with Tanzu workloads. This functionality is also supported by PowerStore and Unity storage arrays.<br />
</span></p>
<p style="background: white;"><span style="color: #222222; font-size: 12pt;">The CSI PowerScale driver version 2.0 and later supports managing v1 snapshots.<br />
</span></p>
<p style="background: white;"><span style="color: #222222; font-size: 12pt;">In order to use Volume Snapshots, ensure the following components have been deployed to your cluster:<br />
</span></p>
<ul>
<li>
<div style="background: white;"><span style="color: #222222; font-size: 12pt;">Kubernetes Volume Snapshot CRDs<br />
</span></div>
</li>
<li>
<div style="background: white;"><span style="color: #222222; font-size: 12pt;">Volume Snapshot Controller<br />
</span></div>
</li>
</ul>
<p style="background: white;"><span style="color: #222222; font-size: 13pt;">Volume Snapshot Class<br />
</span></p>
<p style="background: white;"><span style="color: #222222; font-size: 12pt;">During the installation of CSI PowerScale driver version 2.0, no default Volume Snapshot Class will get created.<br />
</span></p>
<p style="background: white;"><span style="color: #222222; font-size: 12pt;">Following are the manifests for the Volume Snapshot Class:<br />
</span></p>
<ol>
<li>
<div style="background: white;"><span style="color: #222222; font-size: 12pt;">VolumeSnapshotClass<br />
</span></div>
<p style="background: white;">
</li>
</ol>
<ol>
<li>
<div style="background: #f8f8f8;"><span style="color: #8f5902; font-family: Consolas; font-size: 10pt;"><em># For kubernetes version 20 and above (v1 snaps)</em><span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>apiVersion<span style="color: black;">:</span></strong><span style="color: #f8f8f8;"><span style="text-decoration: underline;"><br />
</span><span style="color: #222222;">snapshot.storage.k8s.io/v1<span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>kind<span style="color: black;">:</span></strong><span style="color: #f8f8f8;"><span style="text-decoration: underline;"><br />
</span><span style="color: #222222;">VolumeSnapshotClass<span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>metadata<span style="color: black;">:</span></strong><span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #f8f8f8; font-family: Consolas; font-size: 10pt;"><span style="text-decoration: underline;"><br />
</span><span style="color: #204a87;"><strong>name<span style="color: black;">:</span></strong><span style="color: #f8f8f8;"><span style="text-decoration: underline;"><br />
</span><span style="color: #4e9a06;">&#8220;powerscale-snapclass&#8221;<span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></span></span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>driver<span style="color: black;">:</span></strong><span style="color: #f8f8f8;"><span style="text-decoration: underline;"><br />
</span><span style="color: #222222;">csi-isilon.dellemc.com<span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #8f5902; font-family: Consolas; font-size: 10pt;"><em>#The deletionPolicy of a volume snapshot class can either be Retain or Delete</em><span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #8f5902; font-family: Consolas; font-size: 10pt;"><em>#If the deletionPolicy is Delete, then the underlying storage snapshot is deleted along with the VolumeSnapshotContent object.</em><span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #8f5902; font-family: Consolas; font-size: 10pt;"><em>#If the deletionPolicy is Retain, then both the underlying snapshot and VolumeSnapshotContent remain</em><span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>deletionPolicy<span style="color: black;">:</span></strong><span style="color: #f8f8f8;"><span style="text-decoration: underline;"><br />
</span><span style="color: #222222;">Delete<span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #204a87; font-family: Consolas; font-size: 10pt;"><strong>parameters<span style="color: black;">:</span></strong><span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></div>
</li>
<li>
<div style="background: #f8f8f8;"><span style="color: #f8f8f8; font-family: Consolas; font-size: 10pt;"><span style="text-decoration: underline;"><br />
</span><span style="color: #8f5902;"><em>#IsiPath should match with respective storageClass IsiPath</em><span style="color: #f8f8f8; text-decoration: underline;"><br />
</span></span></span></div>
</li>
</ol>
<p style="background: #f8f8f8;"><span style="color: #f8f8f8; font-family: Consolas; font-size: 10pt;"><span style="text-decoration: underline;"><br />
</span><span style="color: #204a87;"><strong>IsiPath<span style="color: black;">:</span></strong><span style="color: #f8f8f8;"><span style="text-decoration: underline;"><br />
</span><span style="color: #4e9a06;">&#8220;/ifs/data/csi&#8221;<span style="color: #222222;"><br />
</span></span></span></span></span></p>
<p><span style="color: #222222;"><span style="font-family: Open Sans; background-color: white;">The following is a sample manifest for creating a Volume Snapshot using the <strong>v1</strong> snapshot APIs; The following snippet assumes that the persistent volume claim name is testvolume.</span><span style="font-family: Segoe UI; font-size: 12pt;"><br />
</span></span></p>
<p>apiVersion: snapshot.storage.k8s.io/v1<br />
kind: VolumeSnapshot<br />
metadata:<br />
name: pvcsnap<br />
namespace: default<br />
spec:<br />
volumeSnapshotClassName: powerscale-snapclass<br />
source:<br />
persistentVolumeClaimName: testvolume</p>
<p style="background: white;"><span style="color: #222222; font-family: Open Sans; font-size: 12pt;">Once the VolumeSnapshot has been successfully created by the CSI PowerScale driver, a VolumeSnapshotContent object is automatically created. Once the status of the VolumeSnapshot object has the <em>readyToUse</em> field set to <em>true</em>, it is available for use.<br />
</span></p>
<p><img src="https://i1.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe3.png?w=760&#038;ssl=1" alt data-recalc-dims="1" data-lazy-src="https://i1.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe3.png?w=760&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i1.wp.com/volumes.blog/wp-content/uploads/2021/11/110121_1244_DELLEMCPowe3.png?w=760&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript></p>
<p style="background: white;">
<h3><span style="color: #222222;">Creating PVCs with Volume Snapshots as Source<br />
</span></h3>
<p style="background: white;"><span style="color: #222222;">The following is a sample manifest for creating a PVC with a VolumeSnapshot as a source:<br />
</span></p>
<p>apiVersion: v1<br />
kind: PersistentVolumeClaim<br />
metadata:<br />
name: volfromsnap<br />
namespace: default<br />
spec:<br />
storageClassName: powerscale<br />
dataSource:<br />
name: pvcsnap<br />
kind: VolumeSnapshot<br />
apiGroup: snapshot.storage.k8s.io<br />
accessModes:<br />
&#8211; ReadWriteMany<br />
resources:<br />
requests:<br />
storage: 10Gi</p>
<p>you can download the PowerScale CSI plugin, from the VMware marketplace <a href="https://marketplace.cloud.vmware.com/services/details/powerscale-csi-driver1?slug=true" target="_blank" rel="noopener">https://marketplace.cloud.vmware.com/services/details/powerscale-csi-driver1?slug=true</a></p>
<p>Here you can see a video showing how to create ReadWriteMany volumes on TKG Clusters and volumes snapshots using DELL EMC PowerScale with vSphere with Tanzu.</p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="760" height="428" src="https://www.youtube.com/embed/FAWcuY3FLnU?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></div>
<p><span style="font-family: Segoe UI; font-size: 12pt;">A guest post by <a href="https://www.linkedin.com/in/tomer-nahumi-80b607a7/">Tomer Nahumi</a><br />
</span></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-8571" class="share-twitter sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-8571" class="share-linkedin sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-8571" class="share-facebook sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-7144304-8571-6183630134689' data-src='https://widgets.wp.com/likes/#blog_id=7144304&amp;post_id=8571&amp;origin=volumes.blog&amp;obj_id=7144304-8571-6183630134689' data-name='like-post-frame-7144304-8571-6183630134689' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	<div class="post-meta-data">
<span class="posted-on">Posted on <a href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/" rel="bookmark"><time class="entry-date published updated" datetime="2021-11-02T09:29:51+02:00"><span class="post-human-time">2 days ago</span></time></a></span>		<span class="comment-count"><a href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/#respond">0</a></span>
<span class="byline"> By <span class="author vcard"><a class="url fn n" href="https://volumes.blog/author/itzikr/">itzikr</a></span></span>	<span class="post-lead-category"><a href="https://volumes.blog/category/uncategorized/">Uncategorized</a></span>
<span class="terms"><span class="tax-categories">Posted in <a href="https://volumes.blog/category/uncategorized/" rel="category tag">Uncategorized</a></span></span>	</div>
	</section>

	<div class="entry-author contributor">
		<img alt src="https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=140&#038;d=identicon&#038;r=g" class="avatar avatar-140 photo jetpack-lazy-image" height="140" width="140" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=280&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=140&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=140&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=280&#038;d=identicon&#038;r=g 2x' class='avatar avatar-140 photo' height='140' width='140' loading='lazy'/></noscript>		<h2><a href="https://volumes.blog/author/itzikr/">itzikr</a></h2>
		<p>Working For DellEMC as a VP &amp; CTO For XtremIO</p>
	</div>

</article>
<section class="content-comments">

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=7144304&#038;postid=8571&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.4-a.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=0d0d67017dd0f48a9e42e6fd249583aa277246d8#parent=https%3A%2F%2Fvolumes.blog%2F2021%2F11%2F02%2Fdell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</section>
			</div>
<div class="sidebar sidebar-main" role="complementary">

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://volumes.blog/2021/10/30/dell-emc-streaming-data-platform-1-3-is-here/" rel="prev"><b>Next Post</b> Dell EMC Streaming Data Platform 1.3 Is here!</a></div></div>
	</nav><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form method="get" class="search-form" action="https://volumes.blog/" role="search">
	<label>
		<span class="screen-reader">Search for...</span>
		<input type="search" value="" name="s" class="search-field text" placeholder="Search..." />
	</label>
	<button class="search-submit">&#62464;<span class="screen-reader">Search</span></button>
</form>
</div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">
		<h3 class="widgettitle">Recent Posts</h3><nav role="navigation" aria-label="Recent Posts">
		<ul>
											<li>
					<a href="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/" aria-current="page">DELL EMC PowerScale CSI Driver: ReadWriteMany Volumes and Volume Snapshots for VMware vSphere with Tanzu</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/10/30/dell-emc-streaming-data-platform-1-3-is-here/">Dell EMC Streaming Data Platform 1.3 Is here!</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/10/27/dell-emc-powerscale-market-recognition-is-what-really-matters/">Dell EMC PowerScale – Market Recognition is what REALLY matters</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/10/18/introducing-dell-container-storage-modules-csm-part-3-the-how/">Introducing Dell Container Storage Modules (CSM), Part 3 – The ‘How’</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/10/14/introducing-dell-container-storage-modules-csm-part2-the-what/">Introducing Dell Container Storage Modules (CSM), Part2 – The ‘What’</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/10/13/introducing-dell-container-storage-modules-csm-part1-the-why/">Introducing Dell Container Storage Modules (CSM), Part1 – The ‘Why’</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/10/11/dell-openmanage-integration-for-vmware-vcenter-5-4-and-the-dell-esxi-7-0-update-3-iso-are-now-available/">Dell OpenManage Integration for VMware vCenter 5.4 and the Dell ESXi 7.0 Update 3 ISO, are now available.</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/09/28/dell-emc-powerprotect-19-9-part-2-protecting-vmware-virtual-machines-using-transparent-snapshots/">Dell EMC PowerProtect 19.9, Part 2, Protecting VMware Virtual Machines, Using Transparent Snapshots</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/09/20/dell-emc-poweprotect-19-9-part1-dynamic-nas-protection/">Dell EMC PowerProtect 19.9, Part1 &#8211; Dynamic NAS Protection</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/09/09/virtual-storage-integrator-vsi-9-0-is-here/">Virtual Storage Integrator (VSI) 9.0 is here</a>
									</li>
					</ul>

		</nav></div></section><section id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><div class="widget-wrap"><h3 class="widgettitle">Email Subscription</h3>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div>                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
							class="screen-reader-text"
							for="subscribe-field-blog_subscription-3">
							Email Address                        </label>
                        <input type="email" name="email" required="required"
                        			                                                value=""
							id="subscribe-field-blog_subscription-3"
                            placeholder="Email Address"
                        />
                    </p>

					<p id="subscribe-submit"
											>
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://volumes.blog/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="subscribe-blog-blog_subscription-3"/>
						                        <button type="submit"
	                        	                            class="wp-block-button__link"
                            		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Sign me up!                        </button>
                    </p>
				            </form>
		
</div></section><section id="twitter-3" class="widget widget_twitter"><div class="widget-wrap"><h3 class="widgettitle"><a href='http://twitter.com/itzikr'>My Tweets</a></h3><ul class='tweets'>
			<li>
				New Landing page for our devops tools:

<a href="https://www.delltechnologies.com/en-us/solutions/devops/index.htm"> delltechnologies.com/en-us/solution…</a>

Infra as a code, Kubernetes, Ansible, CSI, CSM, you get it..

@<a href='http://twitter.com/DellEMC'>DellEMC</a> 				<a href="http://twitter.com/itzikr/statuses/1455911514578300928" class="timesince">13&nbsp;hours&nbsp;ago</a>
			</li>

			</ul></div></section><!-- Invalid Facebook Page URL --><section id="meta-6" class="widget widget_meta"><div class="widget-wrap"><h3 class="widgettitle">Dell Technologies PowerStore, PowerMax, vXflex OS</h3><nav role="navigation" aria-label="Dell Technologies PowerStore, PowerMax, vXflex OS">
		<ul>
						<li><a rel="nofollow" href="https://volumes.blog/wp-login.php">Log in</a></li>
			<li><a href="https://volumes.blog/feed/">Entries feed</a></li>
			<li><a href="https://volumes.blog/comments/feed/">Comments feed</a></li>

			<li><a href="https://wordpress.org/">WordPress.org</a></li>
		</ul>

		</nav></div></section><section id="media_gallery-5" class="widget widget_media_gallery"><div class="widget-wrap"><div data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/volumes.blog\/2021\/11\/02\/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu\/"}' id='gallery-1' class='gallery galleryid-8571 gallery-columns-3 gallery-size-thumbnail'><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://volumes.blog/generate/'><img width="150" height="150" src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="7417" data-permalink="https://volumes.blog/generate/" data-orig-file="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?fit=1061%2C717&amp;ssl=1" data-orig-size="1061,717" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="generate" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?fit=300%2C203&amp;ssl=1" data-large-file="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?fit=760%2C514&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=120%2C120&amp;ssl=1 120w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
			</div></figure>
		</div>
</div></section></div>
	</div>
</div>


<section class="sidebar sidebar-footer" id="sidebar-footer" role="complementary">
	<div class="container">
		<section id="meta-4" class="widget widget_meta"><div class="widget-wrap"><h3 class="widgettitle">RSS Feed</h3><nav role="navigation" aria-label="RSS Feed">
		<ul>
						<li><a rel="nofollow" href="https://volumes.blog/wp-login.php">Log in</a></li>
			<li><a href="https://volumes.blog/feed/">Entries feed</a></li>
			<li><a href="https://volumes.blog/comments/feed/">Comments feed</a></li>

			<li><a href="https://wordpress.org/">WordPress.org</a></li>
		</ul>

		</nav></div></section>	</div>
</section>

<footer role="contentinfo" id="footer">


	<section class="footer-wrap">

<a class="privacy-policy-link" href="https://volumes.blog/2009/03/28/first-entry-emc-storage-viewer/">First Entry EMC Storage Viewer</a>
		<a></a>
		
		
	</section>


</footer>

<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202144'></script>
	<div style="display:none">
	<div class="grofile-hash-map-ebad424df0120cc6fde01b307ebf399d">
	</div>
	</div>
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 0 0 0 1 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /></feComponentTransfer></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 0 0 0 1 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /></feComponentTransfer></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 0 0 0 1 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /></feComponentTransfer></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 0 0 0 1 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /></feComponentTransfer></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 0 0 0 1 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /></feComponentTransfer></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 0 0 0 1 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /></feComponentTransfer></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 0 0 0 1 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /></feComponentTransfer></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 0 0 0 1 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /></feComponentTransfer></filter></defs></svg>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/volumes.blog\/2021\/11\/02\/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu\/":8571};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2021/11/02/dell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://volumes.blog/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script src='https://platform.twitter.com/widgets.js?ver=20111117' id='twitter-widgets-js'></script>
		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<link rel='stylesheet' id='all-css-75e7d60d92902eee0b47d7b29657cc23' href='https://volumes.blog/_static/??-eJyVjFsKgCAQAC+UbWYEfURnMV3C8oXr4vUjqAP0O8NMy8KkWDFWyJ4PFwlOrFmbC0Ky7JHA6JKY0AM1l7GInaP12Buirv2oXyE+8Ay2sMpZyWFcpJpuzec0Gg==' type='text/css' media='all' />
<script id='jetpack-facebook-embed-js-extra'>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script type='text/javascript'  src='https://volumes.blog/_static/??-eJx9T1kKwjAQvZDpUJeKH+JRJMtY02ZmQpNQensruBRcvh7MW2eMygpn5AwxlNZzgg5z1LaHs2cLpvjgIF4lCz+gIs9Vl1bjp9WKCWL7BM6nDN37oDR70tnL0zlnh+Iw3UUz02IKoh26RfhSQjoJD9MP1grRPEMNGMP0Z96Xzy7aohHpFZJ5tZ/oWDeb7X7X1If1DQEybF8='></script>
<script src='https://volumes.blog/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/../dist/intersection-observer.js?ver=1.1.3' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script src='https://volumes.blog/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/../dist/lazy-images.js?ver=1.1.3' id='jetpack-lazy-images-js'></script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/volumes.blog\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/volumes.blog\/wp-admin\/admin-ajax.php","nonce":"50d704aaa7","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/volumes.blog\/wp-login.php?redirect_to=https%3A%2F%2Fvolumes.blog%2F2021%2F11%2F02%2Fdell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script type='text/javascript'  src='https://volumes.blog/_static/??-eJyVjssOwiAQRX9IOvFVdWH8FEPLpIUCgwy00a+XRZu4cNEu596cM3cKoiWf0CcINnfaMxhMQbYDPLVvocnaKgjEySGz7LBy2leGd9Mq0Lwyxnc1NyIi689GhdUDMhRPxl56ZTGu4B2pbAuWenQoEpFlKM8DedYjilErpD/Jj7kMsFkVhWEoJ7oG1bbhrYyUGe3SiSWYNQ9339fHw/V8qW+nL6zflHk='></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://volumes.blog/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.4-a.1' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-pocket' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-pocket' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202144#ver=202144' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=7144304&postid=8571&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.4-a.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0d0d67017dd0f48a9e42e6fd249583aa277246d8#parent=https%3A%2F%2Fvolumes.blog%2F2021%2F11%2F02%2Fdell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=7144304&postid=8571&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.4-a.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0d0d67017dd0f48a9e42e6fd249583aa277246d8#parent=https%3A%2F%2Fvolumes.blog%2F2021%2F11%2F02%2Fdell-emc-powerscale-csi-driver-readwritemany-volumes-and-volume-snapshots-for-vmware-vsphere-with-tanzu%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202144.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.4-a.1',blog:'7144304',post:'8571',tz:'2',srv:'volumes.blog'} ]);
	_stq.push([ 'clickTrackerInit', '7144304', '8571' ]);
</script>

</body>
</html>
