<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="https://volumes.blog/xmlrpc.php">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="3wZT7sUd08L0kBtnR404qG1xlioF5o0lAWHUhg95xt4" />

	<!-- This site is optimized with the Yoast SEO plugin v16.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Dell EMC PowerStore 2.0 – Part2, DRE​: Double Drive Failure | Itzikr&#039;s Blog</title>
	<link rel="canonical" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre​-double-drive-failure/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Dell EMC PowerStore 2.0 – Part2, DRE​: Double Drive Failure | Itzikr&#039;s Blog" />
	<meta property="og:description" content="In the first post of there series, which you can read here, we covered, in high-level, the features of the 2.0 release of PowerStore. Starting with this post, we will [&hellip;]" />
	<meta property="og:url" content="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre​-double-drive-failure/" />
	<meta property="og:site_name" content="Itzikr&#039;s Blog" />
	<meta property="article:published_time" content="2021-04-21T11:02:53+00:00" />
	<meta property="article:modified_time" content="2021-04-21T15:33:53+00:00" />
	<meta property="og:image" content="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe1.png?fit=1585%2C494&#038;ssl=1" />
	<meta property="og:image:width" content="1585" />
	<meta property="og:image:height" content="494" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@itzikr" />
	<meta name="twitter:site" content="@itzikr" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="itzikr">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="6 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://volumes.blog/#organization","name":"Dell EMC","url":"https://volumes.blog/","sameAs":["https://www.youtube.com/channel/UCccj15VYi_MG1ZYefxSliQQ?view_as=subscriber","https://twitter.com/itzikr"],"logo":{"@type":"ImageObject","@id":"https://volumes.blog/#logo","inLanguage":"en-US","url":"https://i2.wp.com/volumes.blog/wp-content/uploads/2020/05/PowerStore-slant-bezel.jpg?fit=950%2C355&ssl=1","contentUrl":"https://i2.wp.com/volumes.blog/wp-content/uploads/2020/05/PowerStore-slant-bezel.jpg?fit=950%2C355&ssl=1","width":950,"height":355,"caption":"Dell EMC"},"image":{"@id":"https://volumes.blog/#logo"}},{"@type":"WebSite","@id":"https://volumes.blog/#website","url":"https://volumes.blog/","name":"Itzikr&#039;s Blog","description":"Dell EMC Storage, PowerStore, vXflex OS, PowerMax &amp; XtremIO, Virtualization &amp; Containers Technologies","publisher":{"@id":"https://volumes.blog/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://volumes.blog/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe1.png?fit=1585%2C494&ssl=1","contentUrl":"https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe1.png?fit=1585%2C494&ssl=1","width":1585,"height":494},{"@type":"WebPage","@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#webpage","url":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/","name":"Dell EMC PowerStore 2.0 \u2013 Part2, DRE\u200b: Double Drive Failure | Itzikr&#039;s Blog","isPartOf":{"@id":"https://volumes.blog/#website"},"primaryImageOfPage":{"@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#primaryimage"},"datePublished":"2021-04-21T11:02:53+00:00","dateModified":"2021-04-21T15:33:53+00:00","breadcrumb":{"@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/"]}]},{"@type":"BreadcrumbList","@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://volumes.blog/","url":"https://volumes.blog/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/","url":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/","name":"Dell EMC PowerStore 2.0 \u2013 Part2, DRE\u200b: Double Drive Failure"}}]},{"@type":"Article","@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#article","isPartOf":{"@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#webpage"},"author":{"@id":"https://volumes.blog/#/schema/person/e5459f2142cdde1d2afcb4facd0a78a3"},"headline":"Dell EMC PowerStore 2.0 \u2013 Part2, DRE\u200b: Double Drive Failure","datePublished":"2021-04-21T11:02:53+00:00","dateModified":"2021-04-21T15:33:53+00:00","mainEntityOfPage":{"@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#webpage"},"commentCount":0,"publisher":{"@id":"https://volumes.blog/#organization"},"image":{"@id":"https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#primaryimage"},"keywords":"Dell EMC PowerStore 2.0 Dual Drive Failure","articleSection":"PowerStore","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#respond"]}]},{"@type":"Person","@id":"https://volumes.blog/#/schema/person/e5459f2142cdde1d2afcb4facd0a78a3","name":"itzikr","image":{"@type":"ImageObject","@id":"https://volumes.blog/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=96&d=identicon&r=g","contentUrl":"https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=96&d=identicon&r=g","caption":"itzikr"},"description":"Working For DellEMC as a VP &amp; CTO For XtremIO"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Itzikr&#039;s Blog &raquo; Feed" href="https://volumes.blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="Itzikr&#039;s Blog &raquo; Comments Feed" href="https://volumes.blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Itzikr&#039;s Blog &raquo; Dell EMC PowerStore 2.0 – Part2, DRE​: Double Drive Failure Comments Feed" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/volumes.blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-97b340a4f1f8f2fdb2807d482c7da23f' href='https://volumes.blog/_static/??-eJyNUtFSAyEM/CEp9sG2L46f4nAQabwcYQj0vL8XTp3Rep3ywuwyy2aTMEdlOWQIWUcqHoPod8jR2FFP7AqB6ARkMjgVWfIV21mRh/m/hS+VDpC8HgqS0wOxHRXhkExatOSF4NZTMguXrHxCty3MZ5haKp4g8ZdEdNVocJg5qbXWzWTXzRGO9ewtdM/1FYPVHgIkrBLZhr3RpAxiE8aM7f0f1msxo/NQl/ZmLAzMbQVjBR993fy4rINQmZna+iXWAHgBdUEHvHHT3d/ZJHDGuWWFGHzXeIUtGlLEvhb/TXYThnsO7Z984yZ9mZ73h/3p6fF4Oh4+AX4cLKA=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='romero-fonts-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700%7COpen+Sans%3A400%2C700&#038;subset=latin%2Clatin-ext' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script type='text/javascript'  src='https://volumes.blog/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?m=1614096522'></script>
<script src='https://volumes.blog/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script id='romero-script-main-js-extra'>
var js_i18n = {"next":"next","prev":"previous","menu":"Menu"};
</script>
<script type='text/javascript'  src='https://volumes.blog/_static/??wp-includes/js/jquery/jquery-migrate.min.js,wp-content/themes/romero/js/main.js?m=1609869186'></script>
<link rel="https://api.w.org/" href="https://volumes.blog/wp-json/" /><link rel="alternate" type="application/json" href="https://volumes.blog/wp-json/wp/v2/posts/7658" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://volumes.blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://volumes.blog/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/ptYyI-1Zw' />
<link rel="alternate" type="application/json+oembed" href="https://volumes.blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvolumes.blog%2F2021%2F04%2F21%2Fdell-emc-powerstore-2-0-part2-dre%25e2%2580%258b-double-drive-failure%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://volumes.blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvolumes.blog%2F2021%2F04%2F21%2Fdell-emc-powerstore-2-0-part2-dre%25e2%2580%258b-double-drive-failure%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		<style type="text/css">
.widget_twitter li {
	word-wrap: break-word;
}
</style>
<style>
	.masthead h1.site-title a,
	.masthead h1.site-title a:hover,
	.masthead h2.site-description {
		color:#000000;
	}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #343b4f; }
</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/amp/"><style type="text/css" id="custom-colors-css">body.blog .main{color:#afafaf}.masthead .menu-primary #sidebar-menu-toggle:before,.main .pagination span.current,article .post-lead-category a,.infinite-scroll #infinite-handle span,.infinite-scroll #infinite-handle span:hover,#sidebar-menu .widget h3.widgettitle,#sidebar-menu .widget{color:#666}.sidebar-main .widget_calendar thead,.sidebar-main .widget_calendar tbody,.sidebar-main .widget_calendar tfoot,.sidebar-main #wp-calendar a{color:#6d6d6d}.sidebar-main,.sidebar-main .widget a,body .archive,body .blog{color:#afafaf}.sidebar-main .widget{color:#afafaf}.entry-title,.sidebar-main h1,.sidebar-main h2,.sidebar-main h3,.sidebar-main h4,.sidebar-main h5,.sidebar-main h6,h3#comments,h3#comments a,#reply-title{color:#afafaf}.main-content h1,.main-content h2,.main-content h3,.main-content h4,.main-content h5,.main-content h6,.sidebar-footer h1,.sidebar-footer h2,.sidebar-footer h3,.sidebar-footer h4,.sidebar-footer h5,.sidebar-footer h6{color:#1a1a1a}.masthead .menu-primary a,.masthead .actions .menu-primary a,article.post-archive h2.entry-title a{color:#afafaf}.showcase article.post-archive h2.entry-title a{color:#000}.masthead .menu li.page_item_has_children>a:after,.masthead .menu li.menu-item-has-children>a:after{border-top-color:#afafaf}#sidebar-menu .widget a{color:#2b66b9}.blog .main a{color:#89b4e6}.blog .main a:hover{color:#89b4e6}.masthead .menu li.current-menu-item>a{background-color:#ccc}.masthead .menu li.current-menu-item>a{color:#000}body,.masthead .menu-primary{background-color:#343b4f}header.header-overlap,.content-comments{background:#3e475f}input[type=submit],.infinite-scroll #infinite-handle span,.screen-reader-shortcut,.main .contributor a.contributor-posts-link,.masthead .menu-primary #sidebar-menu-toggle:before,.main .pagination span.current,article .post-lead-category a,#sidebar-menu{background:#ebf3ff}input[type=text]:focus,input[type=password]:focus,input[type=email]:focus,input[type=url]:focus,input.text:focus,textarea:focus,select:focus,input.settings-input:focus{outline-color:#ebf3ff}input[type=text]:focus,input[type=password]:focus,input[type=email]:focus,input[type=url]:focus,input.text:focus,textarea:focus,select:focus,input.settings-input:focus,.sidebar-main .widget:before{border-color:#ebf3ff}.sidebar-main .widget.widget_flickr #flickr_badge_uber_wrapper td a,.sidebar-main .widget.widget_flickr #flickr_badge_wrapper td a,a,.sidebar-footer a{color:#145eff}.main .post-navigation .nav-previous a:hover,.main .post-navigation .nav-next a:hover,article.post-archive h2.entry-title a:hover,.sidebar-main .widget a:hover,.menu-social-links ul li a:hover:before,.widget a:hover{color:#ebf3ff}a:hover{color:#f2f7ff}article .post-lead-category a:hover,.masthead .menu-primary #sidebar-menu-toggle:hover::before,.infinite-scroll #infinite-handle span:hover{background:#f2f7ff}.sidebar-menu .widget:before{border-color:#f2f7ff}</style>
<link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="32x32" />
<link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://s0.wp.com/i/webclip.png" />
<meta name="msapplication-TileImage" content="https://s0.wp.com/i/webclip.png" />
<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-52391254-2']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
</head>

<body class="post-template-default single single-post postid-7658 single-format-standard custom-background wp-embed-responsive singular multi-author-false themes-sidebar1-active themes-sidebar2-active themes-no-featured-posts themes-sidebar-menu-inactive widgets-hidden custom-colors">

<a href="#main-content" class="screen-reader-shortcut">Skip to content</a>

<header class="masthead" role="banner">

	<div class="container" id="header-wrapper">
		<div class="action-wrapper">

			<div class="branding">
				<h1 class="site-title">
					<a href="https://volumes.blog/" class="site-logo-link" rel="home" itemprop="url"></a>					<a href="https://volumes.blog/" title="Home" class="site-title-link">
						Itzikr&#039;s Blog					</a>
				</h1>
				<p class="site-description">
					Dell EMC Storage, PowerStore, vXflex OS, PowerMax &amp; XtremIO, Virtualization &amp; Containers Technologies				</p>
			</div>

			<div class="actions">
				<div class="secondary">
										<form method="get" class="search-form" action="https://volumes.blog/" role="search">
	<label>
		<span class="screen-reader">Search for...</span>
		<input type="search" value="" name="s" class="search-field text" placeholder="Search..." />
	</label>
	<button class="search-submit">&#62464;<span class="screen-reader">Search</span></button>
</form>
				</div>

				<nav class="menu-primary menu" role="navigation">
					<h3 class="menu-toggle">Menu</h3>
<div id="nav" class="menu-wrap"><ul>
<li class="page_item page-item-2"><a href="https://volumes.blog/about/">About</a></li>
</ul></div>
				</nav>
			</div>
		</div>
	</div>

	<div class="container container-sidebar-menu">
			</div>

	<div class="container container-header">
	</div>

</header>
<article id="post-7658" class="featured-post" style="background-image:url(https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe1.png?resize=1585%2C494&#038;ssl=1)" >
	<a href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/" class="permalink"><span class="screen-reader-text">Dell EMC PowerStore 2.0 – Part2, DRE​: Double Drive Failure</span></a>
	<section class="entry entry-archive">
		<div class="container">
	<span class="post-lead-category"><a href="https://volumes.blog/category/powerstore/">PowerStore</a></span>
			<h2 class="entry-title">
				<a href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/" rel="bookmark">
					Dell EMC PowerStore 2.0 – Part2, DRE​: Double Drive Failure				</a>
			</h2>
			<div class="excerpt"><p>In the first post of there series, which you can read here, we covered, in high-level, the features of the 2.0 release of PowerStore. Starting with this post, we will [&hellip;]</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-7658" class="share-twitter sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-7658" class="share-linkedin sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-7658" class="share-facebook sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-7144304-7658-6080c3e8b8012' data-src='https://widgets.wp.com/likes/#blog_id=7144304&amp;post_id=7658&amp;origin=volumes.blog&amp;obj_id=7144304-7658-6080c3e8b8012' data-name='like-post-frame-7144304-7658-6080c3e8b8012'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>
		</div>
	</section>
</article>
	<div class="container hfeed">
		<div class="main">
			<div class="main-content article">
<article id="post-7658" class="post-7658 post type-post status-publish format-standard has-post-thumbnail hentry category-powerstore tag-dell-emc-powerstore-2-0-dual-drive-failure post-singular post-has-thumbnail">
	<section class="entry entry-single">
<p><strong>In the first post of there series, which you can read <a href="https://volumes.blog/2021/04/20/dell-emc-powerstore-2-0-part-1-whats-new-in-high-level/" target="_blank" rel="noopener">here,</a> we covered, in high-level, the features of the 2.0 release of PowerStore. Starting with this post, we will go deeper into the features, starting with the enhancements we have made to PowerStore Dynamic Resiliency Engine (DRE)</strong></p>
<p style="margin-left: 19pt;"><span style="color: black;">Before PowerStoreOS 2.0, a cluster was able to handle only a single drive failure at a time until the internal rebuild was finished. I blogged about it <a href="https://volumes.blog/2020/08/17/dell-emc-powerstore-dynamic-resiliency-engine-dre/" target="_blank" rel="noopener">here</a> and you know what? since the GA of PowerStore (one year ago), we did not have a single customer production systems with a dual drive failure which proved the design was RIGHT but as always, we thrive to satisfy our customer&#8217;s requirements, whatever they are so, here we go:</span></p>
<p style="margin-left: 19pt;"><img src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1250_DellEMCPowe1.jpg?w=760&#038;ssl=1" alt data-recalc-dims="1" data-lazy-src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1250_DellEMCPowe1.jpg?w=760&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1250_DellEMCPowe1.jpg?w=760&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript><span style="font-family: Times New Roman; font-size: 12pt;"><br />
</span></p>
<p>We&#8217;ve added a dual parity option to give customers additional protection for mission-critical data within the appliance. Our 100% software-based redundancy and sparing method has <em>always</em> provided a more efficient and automated way to protect data within your array – and now customers with strict dual-parity requirements can benefit as well. DRE is a smarter approach to enterprise-class availability, protecting against simultaneous multi-drive failures while intelligently managing both performance and efficiency.</p>
<ul>
<li>It gives you <strong>more flexibility with up to 98% less management effort</strong> compared to traditional RAID</li>
<li>Automates all the complex processes associated with drive configuration, redundancy, and sparing.</li>
<li>You can add drives one-at-a-time and mix drives sizes to meet cost goals</li>
<li>Everything&#8217;s handled in by intelligent software, right down to replenishing spare capacity if a drive fails, so you never have a lapse in protection levels.</li>
</ul>
<p><em>PowerStore gives you superior resiliency at a lower cost.</em></p>
<p style="margin-left: 19pt;"><span style="color: black;">Starting with PowerStoreOS 2.0, the initial configuration wizard provides an option to enable the Double Drive Failure Tolerance Level feature when more than 7 drives are initially inserted. </span></p>
<p style="margin-left: 19pt;"><span style="color: black;">Once enabled the cluster can handle up to two drive failures at the same time. The drive failure tolerance level can be set for each appliance individually during the initial configuration or when adding an appliance to an existing cluster.</span></p>
<p style="margin-left: 19pt;"><span style="color: black;">Within PowerStore&#8217;s Dynamic Resiliency Engine (DRE), all drives within the system are automatically consumed within an appliance and the appropriate amount of redundancy is applied​</span></p>
<ul style="margin-left: 59pt;">
<li><span style="color: black;">Proprietary algorithms are used to store and protect data within the system​ </span></li>
<li>
<div><span style="color: black;">RAID Resiliency Sets (RRS) are used as fault domains to improve reliability while minimizing spare space overhead​ </span></div>
<ul>
<li><span style="color: black;">RAID Resiliency Sets are also known as fault resiliency sets </span></li>
<li><span style="color: black;">A maximum of 25 drives in each RRS in PowerStore 1.0 </span></li>
</ul>
</li>
<li><span style="color: black;">Having multiple failure domains increases the reliability of the system ​ </span></li>
</ul>
<p><span style="color: black;">Drive fault tolerance is the number of concurrent drive failures, per RRS, that a system can sustain without causing a Data Unavailable/Data Loss (DU/DL) situation​</span></p>
<ul style="margin-left: 59pt;">
<li><span style="color: black;">The RAID protection scheme within the RRS defines how many failures can occur </span></li>
</ul>
<p><img src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe1.png?w=760&#038;ssl=1" alt data-recalc-dims="1" data-lazy-src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe1.png?w=760&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe1.png?w=760&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript><span style="font-family: Times New Roman; font-size: 12pt;"><br />
</span></p>
<p style="margin-left: 36pt;"><span style="color: black;">In the PowerStoreOS 2.0 release, the user has the choice on what fault tolerance level he wishes to assign to the appliance. the drive tolerance level can be set to single drive failure or double drive failure during the initial configuration of an appliance </span></p>
<p style="margin-left: 36pt;"><span style="color: black;">Initial configuration could be initial cluster creation or when the appliance is being added to an existing cluster </span></p>
<p style="margin-left: 36pt;"><span style="color: black;">Configuring the drive tolerance level sets the data protection tolerance level for all RRSs created within the appliance </span></p>
<p style="margin-left: 36pt;"><span style="color: black;">The drive tolerance level is set for the lifetime of the appliance and cannot be changed without a non-data-in-place factory reset </span></p>
<ul style="margin-left: 72pt;">
<li><span style="color: black;">Pre-2.0 systems utilize single drive failure protection </span></li>
</ul>
<p><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black;">Different appliances within a cluster can have different tolerance levels</span><br />
<span style="color: black; text-decoration: underline;"><strong>Tolerance Level Comparison: Single Drive Failure vs. Double Drive Failure</strong></span><br />
</span></p>
<p style="margin-left: 36pt;"><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black;"><strong>Single Drive Failure </strong></span><br />
</span></p>
<ul style="margin-left: 72pt;">
<li><span style="color: black;">Default value </span></li>
<li><span style="color: black;">DRE single parity protection is used within each RRS for user data </span></li>
<li><span style="color: black;">Up to one simultaneous drive failure per RRS without encountering DU/DL </span></li>
<li><span style="color: black;">Metadata and other mirrored data uses 2-way mirroring </span></li>
</ul>
<p><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black;"><strong>Double Drive Failure </strong></span><br />
</span></p>
<ul style="margin-left: 72pt;">
<li><span style="color: black;">DRE dual parity protection is used within each RRS for user data </span></li>
<li><span style="color: black;">Up to two simultaneous drive failure per RRS without encountering DU/DL </span></li>
<li><span style="color: black;">Metadata and other mirrored data uses 3-way mirroring </span></li>
<li><span style="color: black;">Reduced capacity in similar configurations when compared to single </span></li>
</ul>
<p><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black; text-decoration: underline;"><strong>RAID Resiliency Sets &amp; Supported RAID configurations Comparison </strong></span><br />
</span></p>
<p style="margin-left: 36pt;"><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black;"><strong>Single Drive Failure </strong></span><br />
</span></p>
<ul style="margin-left: 72pt;">
<li><span style="color: black;">RRS maximum drive count = 25 drives (Same as previous releases) </span></li>
<li><span style="color: black;">Each RRS reserves one drive worth of spare space </span></li>
<li>
<div><span style="color: black;">4+1 and 8+1 RAID widths supported, RRS width set based on drive count at initialization </span></div>
<ul>
<li><span style="color: black;">4+1 requires a minimum of 6 drives </span></li>
<li><span style="color: black;">8+1 requires a minimum of 10 drives </span></li>
</ul>
</li>
</ul>
<p><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black;"><strong>Double Drive Failure </strong></span><br />
</span></p>
<ul style="margin-left: 72pt;">
<li><span style="color: black;">RRS maximum drive count = 50 drives </span></li>
<li><span style="color: black;">Each RRS reserves one drive worth of spare space </span></li>
<li>
<div><span style="color: black;">4+2, 8+2, and 16+2 RAID widths supported, RRS width set based on drive count at initialization </span></div>
<ul>
<li><span style="color: black;">4+2 requires a minimum of 7 drives </span></li>
<li><span style="color: black;">8+2 requires a minimum of 11 drives </span></li>
<li><span style="color: black;">16+2 requires a minimum of 19 drives </span></li>
</ul>
</li>
</ul>
<ul>
<li><span style="color: black;">RAID widths do not change as drives are added to the system </span></li>
</ul>
<p><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black;"><span style="text-decoration: underline;"><strong>Tolerance Level: Single Drive example </strong></span>Below is an example of the configuration of a RAID Resiliency Set on an appliance containing 12 drives. In this example, the appliance was initialized with 12 drives, and single drive failure was selected as the tolerance level. In this example, the RAID width of 8+1 was selected on the system. This is based on the tolerance level selection and the number of drives within the system at initialization. Capacity from 9 drives is utilized to create the 8+1 protection. Spare space is also reserved from the drives within the RRS as space to use for rebuilds if a failure occurs. This example shows the capacity blocks for each User Data stripe selected in an orderly fashion. This is only for demonstration purposes. Internal algorithms will spread the User Data blocks out efficiently, making the block layout more random.</span><br />
</span></p>
<p><img src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe2.png?w=760&#038;ssl=1" alt data-recalc-dims="1" data-lazy-src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe2.png?w=760&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe2.png?w=760&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript></p>
<p><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black;"><span style="text-decoration: underline;"><strong>Tolerance Level: Double Drive example </strong></span>Below is an example of the configuration of a RAID Resiliency Set on an appliance containing 12 drives. In this example, the appliance was initialized with 12 drives, and double drive failure was selected as the tolerance level. In this example, the RAID width of 8+2 was selected on the system. This is based on the tolerance level selection and the number of drives within the system at initialization. Capacity from 10 drives is utilized to create the 8+2 protection. Spare space is also reserved from the drives within the RRS as space to use for rebuilds if a failure occurs. Note: This example shows the capacity blocks for each User Data stripe selected in an orderly fashion. This is only for demonstration purposes. Internal algorithms will spread the User Data blocks out efficiently, making the block layout more random.</span><br />
<img src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe3.png?w=760&#038;ssl=1" alt data-recalc-dims="1" data-lazy-src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe3.png?w=760&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/volumes.blog/wp-content/uploads/2021/04/042121_1102_DellEMCPowe3.png?w=760&#038;ssl=1" alt="" data-recalc-dims="1" /></noscript><br />
</span></p>
<p style="background: white;"><span style="font-family: Times New Roman; font-size: 12pt;"><span style="color: black;">Below you can see a demonstration video showing a double failure scenario: </span></span></p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='760' height='428' src='https://www.youtube.com/embed/sDQ-jvqwp_A?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent' allowfullscreen='true' style='border:0;' sandbox='allow-scripts allow-same-origin allow-popups allow-presentation'></iframe></span></div>
<p><span style="font-size: 12pt;"><span style="font-family: Times New Roman;"> </span><span style="font-family: Segoe UI;">A guest post by <a href="https://www.linkedin.com/in/tomer-nahumi-80b607a7/">Tomer Nahumi</a></span><span style="font-family: Times New Roman;"><br />
</span></span></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-7658" class="share-twitter sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-7658" class="share-linkedin sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-7658" class="share-facebook sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon" href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-7144304-7658-6080c3e8baa74' data-src='https://widgets.wp.com/likes/#blog_id=7144304&amp;post_id=7658&amp;origin=volumes.blog&amp;obj_id=7144304-7658-6080c3e8baa74' data-name='like-post-frame-7144304-7658-6080c3e8baa74'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	<div class="post-meta-data">
<span class="posted-on">Posted on <a href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/" rel="bookmark"><time class="entry-date published updated" datetime="2021-04-21T14:02:53+03:00"><span class="post-human-time">13 hours ago</span></time></a></span>		<span class="comment-count"><a href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/#respond">0</a></span>
<span class="byline"> By <span class="author vcard"><a class="url fn n" href="https://volumes.blog/author/itzikr/">itzikr</a></span></span>	<span class="post-lead-category"><a href="https://volumes.blog/category/powerstore/">PowerStore</a></span>
<span class="terms"><span class="tax-categories">Posted in <a href="https://volumes.blog/category/powerstore/" rel="category tag">PowerStore</a></span> <span class="tax-tags">Tagged #<a href="https://volumes.blog/tag/dell-emc-powerstore-2-0-dual-drive-failure/" rel="tag">Dell EMC PowerStore 2.0 Dual Drive Failure</a></span></span></span>	</div>
	</section>

	<div class="entry-author contributor">
		<img alt src="https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=140&#038;d=identicon&#038;r=g" class="avatar avatar-140 photo jetpack-lazy-image" height="140" width="140" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=280&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=140&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=140&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/ebad424df0120cc6fde01b307ebf399d?s=280&#038;d=identicon&#038;r=g 2x' class='avatar avatar-140 photo' height='140' width='140' loading='lazy'/></noscript>		<h2><a href="https://volumes.blog/author/itzikr/">itzikr</a></h2>
		<p>Working For DellEMC as a VP &amp; CTO For XtremIO</p>
	</div>

</article>
<section class="content-comments">

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/04/21/dell-emc-powerstore-2-0-part2-dre%E2%80%8B-double-drive-failure/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=7144304&#038;postid=7658&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.6.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=99c0b26ee1946b48673ef06c50993b8fc638ac1e#parent=https%3A%2F%2Fvolumes.blog%2F2021%2F04%2F21%2Fdell-emc-powerstore-2-0-part2-dre%25E2%2580%258B-double-drive-failure%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</section>
			</div>
<div class="sidebar sidebar-main" role="complementary">

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://volumes.blog/2021/04/20/dell-emc-powerstore-2-0-part-1-whats-new-in-high-level/" rel="prev"><b>Next Post</b> Dell EMC PowerStore 2.0 – Part 1, an High-Level Overview</a></div></div>
	</nav><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form method="get" class="search-form" action="https://volumes.blog/" role="search">
	<label>
		<span class="screen-reader">Search for...</span>
		<input type="search" value="" name="s" class="search-field text" placeholder="Search..." />
	</label>
	<button class="search-submit">&#62464;<span class="screen-reader">Search</span></button>
</form>
</div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">
		<h3 class="widgettitle">Recent Posts</h3><nav role="navigation" aria-label="Recent Posts">
		<ul>
											<li>
					<a href="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure/" aria-current="page">Dell EMC PowerStore 2.0 – Part2, DRE​: Double Drive Failure</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/04/20/dell-emc-powerstore-2-0-part-1-whats-new-in-high-level/">Dell EMC PowerStore 2.0 – Part 1, an High-Level Overview</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/04/06/dell-emc-container-storage-module-the-one-about-resiliency/">Dell EMC Container Storage Module, the one about Resiliency</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/04/01/csi-driver-for-dell-emc-powerscale-v1-5/">CSI Driver for DELL EMC PowerScale v1.5</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/03/29/introducing-dell-emc-container-storage-module-authorization/">Introducing DELL EMC Container Storage Module Authorization</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/03/29/csi-driver-for-dell-emc-powerflex-v1-4/">CSI Driver for DELL EMC PowerFlex v1.4</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/03/26/csi-driver-for-dell-emc-powermax-v1-6/">CSI Driver for Dell EMC PowerMax v1.6</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/03/25/ansible-modules-for-dell-emc-powerflex-1-0-is-now-available/">Ansible Modules for Dell EMC PowerFlex 1.0 are now available</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/03/22/dell-openmanage-integration-for-vmware-vcenter-5-3-and-the-dell-esxi-7-0-update-2-iso-are-now-available/">Dell OpenManage Integration for VMware vCenter 5.3 and the Dell ESXi 7.0 Update 2 ISO, are now available.</a>
									</li>
											<li>
					<a href="https://volumes.blog/2021/03/16/dell-powerstore-csi-driver-1-3-for-kubernetes-and-redhat-openshift-whats-new/">Dell PowerStore CSI Driver 1.3 for Kubernetes and RedHat OpenShift – What’s New?</a>
									</li>
					</ul>

		</nav></div></section><section id="blog_subscription-3" class="widget widget_blog_subscription jetpack_subscription_widget"><div class="widget-wrap"><h3 class="widgettitle">Email Subscription</h3>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div>                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-3">
							Email Address                        </label>
                        <input type="email" name="email" required="required"
                        			                                                value=""
                            id="subscribe-field-blog_subscription-3"
                            placeholder="Email Address"
                        />
                    </p>

					<p id="subscribe-submit"
											>
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://volumes.blog/2021/04/21/dell-emc-powerstore-2-0-part2-dre%E2%80%8B-double-drive-failure/"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Sign me up!                        </button>
                    </p>
				            </form>
		
</div></section><section id="twitter-3" class="widget widget_twitter"><div class="widget-wrap"><h3 class="widgettitle"><a href='http://twitter.com/itzikr'>My Tweets</a></h3><ul class='tweets'>
			<li>
				Le PowerStore 500 <a href="https://twitter.com/LeMagIT/status/1384933848702672898"> twitter.com/LeMagIT/status…</a> 				<a href="http://twitter.com/itzikr/statuses/1384958092534767619" class="timesince">4&nbsp;hours&nbsp;ago</a>
			</li>

			
			<li>
				New Blog Post:
@<a href='http://twitter.com/DellEMC'>DellEMC</a>  PowerStore 2.0 – Part2, DRE​: Double Drive Failure
<a href="http://volumes.blog/2021/04/21/del"> volumes.blog/2021/04/21/del</a>…

Or, when we say we listen, we do. 				<a href="http://twitter.com/itzikr/statuses/1384934064164069383" class="timesince">6&nbsp;hours&nbsp;ago</a>
			</li>

			</ul></div></section><!-- Invalid Facebook Page URL --><section id="meta-6" class="widget widget_meta"><div class="widget-wrap"><h3 class="widgettitle">Dell Technologies PowerStore, PowerMax, vXflex OS</h3><nav role="navigation" aria-label="Dell Technologies PowerStore, PowerMax, vXflex OS">
		<ul>
						<li><a rel="nofollow" href="https://volumes.blog/wp-login.php">Log in</a></li>
			<li><a href="https://volumes.blog/feed/">Entries feed</a></li>
			<li><a href="https://volumes.blog/comments/feed/">Comments feed</a></li>

			<li><a href="https://wordpress.org/">WordPress.org</a></li>
		</ul>

		</nav></div></section><section id="media_gallery-5" class="widget widget_media_gallery"><div class="widget-wrap"><div data-carousel-extra='{"blog_id":1,"permalink":"https:\/\/volumes.blog\/2021\/04\/21\/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure\/"}' id='gallery-1' class='gallery galleryid-7658 gallery-columns-3 gallery-size-thumbnail'><figure class='gallery-item'>
			<div class='gallery-icon landscape'>
				<a href='https://volumes.blog/generate/'><img width="150" height="150" src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="7417" data-permalink="https://volumes.blog/generate/" data-orig-file="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?fit=1061%2C717&amp;ssl=1" data-orig-size="1061,717" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="generate" data-image-description="" data-medium-file="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?fit=300%2C203&amp;ssl=1" data-large-file="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?fit=760%2C514&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=120%2C120&amp;ssl=1 120w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/volumes.blog/wp-content/uploads/2021/02/generate.png?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
			</div></figure>
		</div>
</div></section></div>
	</div>
</div>


<section class="sidebar sidebar-footer" id="sidebar-footer" role="complementary">
	<div class="container">
		<section id="meta-4" class="widget widget_meta"><div class="widget-wrap"><h3 class="widgettitle">RSS Feed</h3><nav role="navigation" aria-label="RSS Feed">
		<ul>
						<li><a rel="nofollow" href="https://volumes.blog/wp-login.php">Log in</a></li>
			<li><a href="https://volumes.blog/feed/">Entries feed</a></li>
			<li><a href="https://volumes.blog/comments/feed/">Comments feed</a></li>

			<li><a href="https://wordpress.org/">WordPress.org</a></li>
		</ul>

		</nav></div></section>	</div>
</section>

<footer role="contentinfo" id="footer">


	<section class="footer-wrap">

<a class="privacy-policy-link" href="https://volumes.blog/2009/03/28/first-entry-emc-storage-viewer/">First Entry EMC Storage Viewer</a>
		<a></a>
		
		
	</section>


</footer>

<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202116'></script>
	<div style="display:none">
	<div class="grofile-hash-map-ebad424df0120cc6fde01b307ebf399d">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/volumes.blog\/2021\/04\/21\/dell-emc-powerstore-2-0-part2-dre%e2%80%8b-double-drive-failure\/":7658};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2021/04/21/dell-emc-powerstore-2-0-part2-dre%E2%80%8B-double-drive-failure/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://volumes.blog/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script src='https://platform.twitter.com/widgets.js?ver=20111117' id='twitter-widgets-js'></script>
<link rel='stylesheet' id='all-css-117d2a2623fa457a06d4676c3b229b80' href='https://volumes.blog/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.css?m=1617123580' type='text/css' media='all' />
<script id='jetpack-facebook-embed-js-extra'>
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
</script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/volumes.blog\/wp-admin\/admin-ajax.php","nonce":"6b3e89fe46","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/volumes.blog\/wp-login.php?redirect_to=https%3A%2F%2Fvolumes.blog%2F2021%2F04%2F21%2Fdell-emc-powerstore-2-0-part2-dre%25e2%2580%258b-double-drive-failure%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
</script>
<script type='text/javascript'  src='https://volumes.blog/_static/??-eJytUu9uAiEMf6EhcTHGL8seZeGger0rlFE4cz69OL3NZd6myT4R2v7+UfZRWQ4ZQtaRyg6D6A5yNLbXbxisbgqS07HlzOFyLDyGRSdP+59Qyw2x7UU7lKy7r4IyAb3JyBOyclNxIKeh2tmBEBsH7or8esQb4ZDGma5l76sNlSDS+Iu9G8m2xkLD3CvwzTf1OewAwXHSpmSugTLaqaPIHEZ1zqIl2Y9klSMJ2FNwbgTSAElFpnGLRP8tdlV67A0iS/YgUpGPAbv3AnUpk6cEgocHKQj7mqDyFGhNcATpDrxnV6jCcgseVGYm0VU8chAcQA3ogG9UZn5Pvf61fNOjeMhn41tO/v6A1iQuAvS5ualwkXv1L8v1cvO8Xq02myNjJlq7'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://volumes.blog/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.6.1' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-pocket' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-pocket' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202116#ver=202116' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=7144304&postid=7658&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=99c0b26ee1946b48673ef06c50993b8fc638ac1e#parent=https%3A%2F%2Fvolumes.blog%2F2021%2F04%2F21%2Fdell-emc-powerstore-2-0-part2-dre%25E2%2580%258B-double-drive-failure%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=7144304&postid=7658&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=identicon&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=99c0b26ee1946b48673ef06c50993b8fc638ac1e#parent=https%3A%2F%2Fvolumes.blog%2F2021%2F04%2F21%2Fdell-emc-powerstore-2-0-part2-dre%25E2%2580%258B-double-drive-failure%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202116.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'7144304',post:'7658',tz:'3',srv:'volumes.blog'} ]);
	_stq.push([ 'clickTrackerInit', '7144304', '7658' ]);
</script>

</body>
</html>
<!--
	generated in 0.186 seconds
	69825 bytes batcached for 300 seconds
-->
